Всё про Linux

Board index Общие разделы Оффтопик

Description: Разговоры обо всём
Moderator: exooman

Post #4421by try_out » 05.06.2021, 17:03

Для mesa у меня репозиторий oibaf/graphcs-drivers добавлен.
ASUS X550LC /Linux Mint Mate
try_out M
Avatar
Location: РФ, Башкирия
Posts: 3165

Post #4422by Юрий Небесный » 07.06.2021, 09:18

на арчах и манжарах сложности с amd. пока лучше всех дела на убунтах
Linux Plasma | Ryzen 5, 32Gb, SSD M2, RX 590 | BenQ 27 | Wacom | Microsoft Ergo | Gun Tin tea
http://dezigner.tilda.ws
Юрий Небесный M
Avatar
Posts: 2125

Post #4423by try_out » 07.06.2021, 10:43

Юрий Небесный wrote:на арчах и манжарах сложности с amd. пока лучше всех дела на убунтах
Вчера ставил Mint на новый комп с Radeon RX 550. Всё завелось без проблем.
А с Nvidia 1060 возникла проблема — невозможно выйти в BIOS через порт HDMI. Или меню загрузки посмотреть. Показывала только на рабочем столе. Победить не смогли, установили этот Радеон.
ASUS X550LC /Linux Mint Mate
try_out M
Avatar
Location: РФ, Башкирия
Posts: 3165

Post #4424by grayich » 07.06.2021, 12:30

try_out wrote:А с Nvidia 1060 возникла проблема — невозможно выйти в BIOS через порт HDMI
дичь якась :facepalm:
Linux
grayich M
Avatar
Location: Харьков
Posts: 5821

Post #4425by try_out » 02.01.2022, 00:11

А кто-нибудь может подсказать, как запустить в Linux OpenCL на Radeon RX550 в Blender 2.93?
ASUS X550LC /Linux Mint Mate
try_out M
Avatar
Location: РФ, Башкирия
Posts: 3165

Post #4426by grayich » 02.01.2022, 00:31

try_out wrote:как запустить в Linux OpenCL на Radeon RX550 в Blender 2.93?
установить в систему пакеты с opencl
обычно это что-то типа opencl-mesa
проверить что opencl установлен можно с помощью clinfo - выведет информацию о версии и т.п.

ну и в блендере в настройках выбрать соответственно для циклов OpenCL

з.ы.
впрочем забей, в блендер 3 от него отказались, пилят чёто там другое
Linux
grayich M
Avatar
Location: Харьков
Posts: 5821

Post #4427by try_out » 02.01.2022, 00:58

grayich, чё-то пакетов не вижу таких, сейчас ещё гляну.
grayich wrote:ну и в блендере в настройках выбрать соответственно для циклов OpenCL
это понятно, но не выбирается, если нет поддержки.
grayich wrote:в блендер 3 от него отказались, пилят чёто там другое
Мне пока надо в 2.93.
ASUS X550LC /Linux Mint Mate
try_out M
Avatar
Location: РФ, Башкирия
Posts: 3165

Post #4428by grayich » 02.01.2022, 05:16

ну ищи пакеты по словам opencl ocl ocl-icd
ненаю как их в минте звать
Linux
grayich M
Avatar
Location: Харьков
Posts: 5821

Post #4429by try_out » 02.01.2022, 10:10

Попробовал под Windows на этом же компе.
На процессоре быстрее рендерит, чем на видяхе этой.
ASUS X550LC /Linux Mint Mate
try_out M
Avatar
Location: РФ, Башкирия
Posts: 3165

Post #4430by Юрий Небесный » 03.01.2022, 09:07

try_out wrote:как запустить в Linux OpenCL на Radeon RX550
https://www.amd.com/ru/support - качаешь предыдущую версию драйвера
там по мануалам ставишь
я вот так накатываю: ./amdgpu-install --no-dkms --opencl=legacy
Linux Plasma | Ryzen 5, 32Gb, SSD M2, RX 590 | BenQ 27 | Wacom | Microsoft Ergo | Gun Tin tea
http://dezigner.tilda.ws
Юрий Небесный M
Avatar
Posts: 2125

Post #4431by BigGoga » 26.01.2022, 21:57

Ребята, всем привет.
Linux Mint 20.3 x64. DE - Cinamon
Подскажите как в линксе переустановить (установить) драйвера Nvidia.
Стандартные варианты через GUI которые я знал и сипользовал выдают вот ошибку

Image

Что бы я не делал возникает непонятная ошибка.
Как можно всё исправить не переустанавливая линукс


Пытаюсь удалить пакеты чтоб потом переустановить, выдаёт вот такие ошибки
Code: Select all
E: /var/cache/apt/archives/libnvidia-gl-470_470.86-0ubuntu0.20.04.2_i386.deb: new libnvidia-gl-470:i386 package pre-installation script subprocess returned error exit status 2
E: /var/cache/apt/archives/libnvidia-gl-470_470.86-0ubuntu0.20.04.2_amd64.deb: new libnvidia-gl-470:amd64 package pre-installation script subprocess returned error exit status 2

Вот ещё одна ошибка
Image
BigGoga M
Location: Belarus.Minsk
Posts: 305

Post #4432by mageaster » 26.01.2022, 23:16

Видюха-то какая? А то может 470-ми дровами и не поддерживается вовсе?
Меньше слов, больше дела!
AMD Phenom II X6 1055T, Ryzen 7 2700X 4 16 32 GiB RAM, Nvidia GeForce GTX 550 Ti RTX 2060, Kubuntu 18.04 20.04
Мой WIP
mageaster M
теоретик
Avatar
Location: оттуда
Posts: 3185

Post #4433by BigGoga » 27.01.2022, 09:32

mageaster wrote:Видюха-то какая?
Вот жешь, самое главное и не написал. GTX 1080Ti
BigGoga M
Location: Belarus.Minsk
Posts: 305

Post #4434by grayich » 27.01.2022, 09:46

чёто где-то не того,
BigGoga, попробуй сначала бахнуть всё в каталоге /var/cache/apt/archives/
осторожно, не ошибиться rm -rf /var/cache/apt/archives/*
потом обновить всю базу пакетов sudo apt-get update вроде
а потом уже чёто делать
Linux
grayich M
Avatar
Location: Харьков
Posts: 5821

Post #4435by BigGoga » 27.01.2022, 19:08

grayich wrote:опробуй сначала бахнуть всё в каталоге /var/cache/apt/archives/
Всё бахнул
Потом пытался всё почистить командой autoremove
Code: Select all
sudo apt autoremove
[sudo] пароль для biggoga:           
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Вы можете запустить «apt --fix-broken install» для исправления этих ошибок.
Следующие пакеты имеют неудовлетворённые зависимости:
 libnvidia-ifr1-470 : Зависит: libnvidia-gl-470 но он не установлен
 libnvidia-ifr1-470:i386 : Зависит: libnvidia-gl-470:i386 но он не установлен
 nvidia-driver-470 : Зависит: libnvidia-gl-470 (= 470.86-0ubuntu0.20.04.2) но он не установлен
                     Рекомендует: libnvidia-gl-470:i386 (= 470.86-0ubuntu0.20.04.2)
E: Неудовлетворённые зависимости. Попытайтесь выполнить «apt --fix-broken install», не указывая имени пакета (или указав решение).
************************** $ apt --fix-broken install
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Исправление зависимостей… Готово
Следующие пакеты устанавливались автоматически и больше не требуются:
  linux-headers-5.4.0-91 linux-headers-5.4.0-91-generic linux-image-5.4.0-91-generic linux-modules-5.4.0-91-generic linux-modules-extra-5.4.0-91-generic
  mint-backgrounds-uma
Для их удаления используйте «sudo apt autoremove».
Будут установлены следующие дополнительные пакеты:
  libnvidia-gl-470 libnvidia-gl-470:i386
Следующие НОВЫЕ пакеты будут установлены:
  libnvidia-gl-470 libnvidia-gl-470:i386
Обновлено 0 пакетов, установлено 2 новых пакетов, для удаления отмечено 0 пакетов, и 4 пакетов не обновлено.
Установлено или удалено не до конца 7 пакетов.
Необходимо скачать 165 MB архивов.
После данной операции объём занятого дискового пространства возрастёт на 427 MB.
Хотите продолжить? [Д/н] y
Пол:1 http://archive.ubuntu.com/ubuntu focal-updates/restricted i386 libnvidia-gl-470 i386 470.86-0ubuntu0.20.04.2 [21,2 MB]
Пол:2 http://archive.ubuntu.com/ubuntu focal-updates/restricted amd64 libnvidia-gl-470 amd64 470.86-0ubuntu0.20.04.2 [144 MB]
Получено 165 MB за 20с (8.296 kB/s)                                                                                                                           
(Чтение базы данных … на данный момент установлено 461838 файлов и каталогов.)
Подготовка к распаковке …/libnvidia-gl-470_470.86-0ubuntu0.20.04.2_i386.deb …
отклонение /usr/lib/i386-linux-gnu/libGL.so.1 в /usr/lib/i386-linux-gnu/libGL.so.1.distrib из-за nvidia-340
dpkg-divert: ошибка: несовпадение с пакетом
  при удалении «отклонение /usr/lib/i386-linux-gnu/libGL.so.1 из-за libnvidia-gl-470»
  найдено «отклонение /usr/lib/i386-linux-gnu/libGL.so.1 в /usr/lib/i386-linux-gnu/libGL.so.1.distrib из-за nvidia-340»
dpkg: ошибка при обработке архива /var/cache/apt/archives/libnvidia-gl-470_470.86-0ubuntu0.20.04.2_i386.deb (--unpack):
 new libnvidia-gl-470:i386 package pre-installation script subprocess returned error exit status 2
Подготовка к распаковке …/libnvidia-gl-470_470.86-0ubuntu0.20.04.2_amd64.deb …
отклонение /usr/lib/x86_64-linux-gnu/libGL.so.1 в /usr/lib/x86_64-linux-gnu/libGL.so.1.distrib из-за nvidia-340
dpkg-divert: ошибка: несовпадение с пакетом
  при удалении «отклонение /usr/lib/x86_64-linux-gnu/libGL.so.1 из-за libnvidia-gl-470»
  найдено «отклонение /usr/lib/x86_64-linux-gnu/libGL.so.1 в /usr/lib/x86_64-linux-gnu/libGL.so.1.distrib из-за nvidia-340»
dpkg: ошибка при обработке архива /var/cache/apt/archives/libnvidia-gl-470_470.86-0ubuntu0.20.04.2_amd64.deb (--unpack):
 new libnvidia-gl-470:amd64 package pre-installation script subprocess returned error exit status 2
При обработке следующих пакетов произошли ошибки:
 /var/cache/apt/archives/libnvidia-gl-470_470.86-0ubuntu0.20.04.2_i386.deb
 /var/cache/apt/archives/libnvidia-gl-470_470.86-0ubuntu0.20.04.2_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Added after 3 minutes 4 seconds:
Линукс теперь да же не хочет nouveau ставить
BigGoga M
Location: Belarus.Minsk
Posts: 305

Post #4436by mageaster » 27.01.2022, 21:24

Ну а
Code: Select all
apt --fix-broken install

пробовал выполнить?
Меньше слов, больше дела!
AMD Phenom II X6 1055T, Ryzen 7 2700X 4 16 32 GiB RAM, Nvidia GeForce GTX 550 Ti RTX 2060, Kubuntu 18.04 20.04
Мой WIP
mageaster M
теоретик
Avatar
Location: оттуда
Posts: 3185

Post #4437by BigGoga » 28.01.2022, 10:38

Да. Почти все ошибки там и посыпались если код внимательно посмотреть
BigGoga M
Location: Belarus.Minsk
Posts: 305

Previous

Return to Оффтопик

Who is online (over the past 5 minutes)

Users browsing this forum: 1 guest

cron