Всё про Linux

Board index Общие разделы Оффтопик

Description: Разговоры обо всём
Moderator: exooman

Post #181by nicolo » 20.03.2014, 20:51

mageaster
да, все получилось!
может кому пригодиться:
нужно "освободить" <Alt> и выставить к примеру <Super>
Spoiler
Image
nicolo M
Location: Kazan
Posts: 40

Post #182by Korchy » 22.03.2014, 20:56

Подскажите, кто разбирается в Debian.
Ситуация такая: два года назад был установлен сервер на vds. Debian 5. Использовал такие репозитории:
deb http://http.us.debian.org/debian stable main contrib non-free
deb http://non-us.debian.org/debian-non-US stable/non-US main contrib non-free
deb http://security.debian.org stable/updates main contrib non-free
Сейчас нужно доустановить расширение php_curl, которое тогда установлено не было.
Репозитория non-us насколько я понял больше не существует, закомментировал его.
Если теперь пытаюсь просто установить через
apt-get install php_curl
выдается предупреждение о замене/установке/модификации пакетов на два экрана, выдается предупреждение "продолжайте только если вы точно знаете что делает" и нужно набрать аж "Yes i do", чтобы продолжить. Пробовал продолжать, выдается три страницы информации, php_curl так и не появляется. Как бы слишком много изменений кажется для доустановки одного расширения.
Я пробовал с этими же репозиториями поставить сервер с нуля (экспериментирую на виртуальной машине), даже ssh не могу поставить, выдаются предупреждения о несовместимости пакетов и что-то еще.
Пробовал использовать архивный репозиторий
deb http://archive.debian.org/debian/ lenny main
т.к. насколько я понял debian 5 ушел в архив и больше не поддерживается.
Сервер ставится, все нормально, но ставится php версии 5.2, а мне для сервера нужен 5.3.3 минимум.

В общем вопрос: как правильно или доустановить расширение php_curl на существующий сервер или поставить с нуля сервер на debian 5?
Korchy M
Avatar
Posts: 3024



Post #183by andreymal » 23.03.2014, 13:04

Korchy wrote:Debian 5
8-O
Эмм... А поновее ничего не нашлось? 6 хотя бы... Полтора года назад я его ставил.
Читая эту подпись, вы впустую потратили 5 секунд своей жизни.
andreymal M
Avatar
Posts: 1195

  • 1

Post #184by nautilus » 23.03.2014, 13:10

может отредактировать sources.list и apt-get update & apt-get dist-upgrade ?:-|
nautilus
Avatar
Location: Украина, Хмельницкий
Posts: 879

Post #185by Korchy » 23.03.2014, 13:41

andreymal,
andreymal wrote:А поновее ничего не нашлось? 6 хотя бы... Полтора года назад я его ставил.
Это изначально ставит хостер. Что есть, с тем и приходится работать.

nautilus,
nautilus wrote:может отредактировать sources.list
Как?
Korchy M
Avatar
Posts: 3024



Post #186by andreymal » 23.03.2014, 13:45

Korchy wrote:Это изначально ставит хостер.
Вот странный какой-то хостер.
Читая эту подпись, вы впустую потратили 5 секунд своей жизни.
andreymal M
Avatar
Posts: 1195

Post #187by girafenok » 23.03.2014, 13:57

С Debian не работаю, но как я понял в Debain Lenny нет php5.3. Надоставить ручками из стороннего репозитория.
Вот нашел ссылку http://mtehrani30.blogspot.ru/2011/07/debian-lenny-update-php-52-to-53.html
Выполнять после красной надписи Update.
Не пробовал, за последствия не ручаюсь ).
girafenok
рендер-фермер
рендер-фермер
Posts: 657

Post #188by Korchy » 23.03.2014, 14:03

andreymal,
http://masterhost.ru/service/hosting/vps/unix/

girafenok,
У меня стоял php 5.3 с репозиториев stable, все было нормально, я писал в первом посте. Проблема в том, что сейчас это не работает.
Korchy M
Avatar
Posts: 3024



Post #189by girafenok » 23.03.2014, 14:09

Korchy,
Не нашел в Debian Lenny php 5.3.
Могу только посоветовать сменить хостера. Неадекватная цена для такой конфигурации, маленький выбор дистрибутивов.
girafenok
рендер-фермер
рендер-фермер
Posts: 657

Post #190by Korchy » 23.03.2014, 14:13

girafenok,
girafenok wrote:Могу только посоветовать сменить хостера. Неадекватная цена для такой конфигурации, маленький выбор дистрибутивов.
Ну, это уже на крайний случай, если не удастся решить проблему. В принципе хостер нормальный. Это первая проблема, возникшая за два с половиной года пользования.
Korchy M
Avatar
Posts: 3024



Post #191by nautilus » 23.03.2014, 17:29

Korchy wrote:Как?
я бы сделал так:
Code: Select all
#nano /etc/apt/sources.list
приводим к виду:
Code: Select all
deb http://ftp.debian.org/debian/ wheezy main non-free contrib
deb-src http://ftp.debian.org/debian/ wheezy main non-free contrib

deb http://security.debian.org/ wheezy/updates main contrib non-free
deb-src http://security.debian.org/ wheezy/updates main contrib non-free

# wheezy-updates, previously known as 'volatile'
deb http://ftp.debian.org/debian/ wheezy-updates main contrib non-free
deb-src http://ftp.debian.org/debian/ wheezy-updates main contrib non-free

# wheezy-backports
deb http://ftp.debian.org/debian/ wheezy-backports main contrib non-free
потом:
Code: Select all
#apt-get update
#apt-get dist-upgrade
з.ы. не кидайтесь тапками, я обычный юзер, не админ и не программер ':-)
nautilus
Avatar
Location: Украина, Хмельницкий
Posts: 879

Post #192by Korchy » 23.03.2014, 21:38

nautilus,
nautilus wrote:я обычный юзер, не админ
Мне хуже. Я программер, которому приходится разбираться и за администратора :)

nautilus wrote:я бы сделал так:
С репозиторием wheezy на upt-get upgrade валится ошибка:
dpkg-deb: file /var/cache/apt/archives/mysql-common_5.5.35+dfsg-0+wheezy1_all.deb contains ununderstood data member mata.tar.xz, giving up
dpgk: error processing /var/cache/apt/archives/mysql-common_5.5.35+dfsg-0+wheezy1_all.deb (--unpack)
subprocess dpdk-deb --fsys-tarfile returned error exti status 2

и видимо раньше, выше по экрану такая же ошибка выдавалась для traceroute

Added after 46 minutes 34 seconds:
сначала пробовал просто upgrade, попробовал dist-upgrade
все равно получаю ошибку
errror: something failed while migrating
error: unable to migrate to dependency based boot squencing
dpkg: error processing sysv-rc (--configure)
subprocess installed post-installation script returned error exit status 1
errors were encountered while processing: sysv-rc
Korchy M
Avatar
Posts: 3024



Post #193by nautilus » 23.03.2014, 22:26

Korchy, попробуйте через aptitude, он более гибкий и должен разрулить :)
Я пользуюсь apt-get из-за неумения пользоваться aptitude, он как начнет что-то спрашиватяь, я сразу =-O

error: unable to migrate to dependency based boot squencing
так понимаю, не хочет обновляться через версию, пробуйте вместо wheezy репу squeeze.
вот, должно помочь.
nautilus
Avatar
Location: Украина, Хмельницкий
Posts: 879

Post #194by Korchy » 23.03.2014, 22:56

nautilus,
nautilus wrote:пробуйте вместо wheezy репу squeeze

С squeeze я пробовал. Вроде получается, но я вводил просто apt-get upgrade а на apt-get dist-upgrade. Т.е. насколько я понимаю не обновлял ядро а просто обновил пакеты. Насколько такой результат получается рабочим и стабильным?
Korchy M
Avatar
Posts: 3024



Post #195by nautilus » 23.03.2014, 22:59

Korchy wrote:вводил просто apt-get upgrade а на apt-get dist-upgrade
не скажу, не знаю, никогда так не делал :(
nautilus
Avatar
Location: Украина, Хмельницкий
Posts: 879

Post #196by Стефан » 24.03.2014, 08:17

Нужно использовать дополнительно sudo - это означает выполнение команды от рута.
Стефан M
Avatar
Posts: 793

Post #197by nautilus » 24.03.2014, 13:04

Стефан wrote:Нужно использовать дополнительно sudo - это означает выполнение команды от рута.
Стефан, шутить изволите ?:-|
# - означает, что действия выполняются от рута.
Не все используют sudo, я предпочитаю su.
nautilus
Avatar
Location: Украина, Хмельницкий
Posts: 879

Post #198by grayich » 24.03.2014, 13:15

nautilus wrote:# - означает, что действия выполняются от рута.
# - означает только что PROMPT такого вида, поэтому не всегда #=root
Linux
grayich M
Avatar
Location: Харьков
Posts: 5821

  • 1

Post #199by andreymal » 24.03.2014, 14:35

Но все-таки вероятность того, что # не root, стремится к нулю :)
Читая эту подпись, вы впустую потратили 5 секунд своей жизни.
andreymal M
Avatar
Posts: 1195

Post #200by Korchy » 24.03.2014, 15:00

В общем проблема оказывается нерешаема. Звонок в техподдержку тоже решения не принес.
Так что видимо нужно искать другой хостинг. Посоветуйте, кто знает хороший стабильный хостинг с VPS (нужно держать запущенными собственные сокет-сервера)?
Korchy M
Avatar
Posts: 3024



PreviousNext

Return to Оффтопик

Who is online (over the past 5 minutes)

Users browsing this forum: 2 guests